summaryrefslogtreecommitdiff
path: root/package/libubox
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2014-03-20 23:17:10 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-03-23 21:19:21 +0100
commit2f2becd52210dd4376b7468708c8d63b446b1c23 (patch)
tree77048e0882ef3eac8c391aae8e5ab5c425213485 /package/libubox
parent74af345cff8a98bbabad6b33ef124a1fe2eb1a99 (diff)
libubox: new package
[Peter: needs !static, use += for _DEPENDENCIES/_CONF_OPT] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libubox')
-rw-r--r--package/libubox/Config.in13
-rw-r--r--package/libubox/libubox.mk18
2 files changed, 31 insertions, 0 deletions
diff --git a/package/libubox/Config.in b/package/libubox/Config.in
new file mode 100644
index 000000000..d45806722
--- /dev/null
+++ b/package/libubox/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBUBOX
+ bool "libubox"
+ depends on !BR2_PREFER_STATIC_LIB
+ help
+ This library originates from the OpenWrt project to
+ handle the configuration file infrastructure, but can
+ also be used for the same purposes in projects other
+ than OpenWrt.
+
+ http://nbd.name/gitweb.cgi?p=luci2/libubox.git;a=summary
+
+comment "libubox needs a toolchain w/ dynamic library"
+ depends on BR2_PREFER_STATIC_LIB
diff --git a/package/libubox/libubox.mk b/package/libubox/libubox.mk
new file mode 100644
index 000000000..0743acca1
--- /dev/null
+++ b/package/libubox/libubox.mk
@@ -0,0 +1,18 @@
+################################################################################
+#
+# libubox
+#
+################################################################################
+
+LIBUBOX_VERSION = bbd846ec2d72b2629758b69dc122ac0b0f2c3e4b
+LIBUBOX_SITE = git://nbd.name/luci2/libubox.git
+LIBUBOX_LICENSE = LGPLv2.1, GPLv2, BSD-3c, MIT
+LIBUBOX_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_LUA),y)
+ LIBUBOX_DEPENDENCIES += lua
+else
+ LIBUBOX_CONF_OPT += -DBUILD_LUA:BOOL=OFF
+endif
+
+$(eval $(cmake-package))