summaryrefslogtreecommitdiff
path: root/package/opengl
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-04-05 17:21:39 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-05 19:20:50 +0200
commit2bb9df30ad8736567dd4f9244e255ddb37171d1d (patch)
treee0529f52ef43889f6ac2ae6b4a70f57e464436e6 /package/opengl
parentec0de5d26b082aff298cd907c8db8f7675e7865d (diff)
package/libegl: rename the _HAS and _PROVIDES variables
The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libegl to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/opengl')
-rw-r--r--package/opengl/libegl/Config.in6
-rw-r--r--package/opengl/libegl/libegl.mk4
2 files changed, 5 insertions, 5 deletions
diff --git a/package/opengl/libegl/Config.in b/package/opengl/libegl/Config.in
index 2d81a2077..8401bb22e 100644
--- a/package/opengl/libegl/Config.in
+++ b/package/opengl/libegl/Config.in
@@ -1,6 +1,6 @@
-config BR2_PACKAGE_HAS_OPENGL_EGL
+config BR2_PACKAGE_HAS_LIBEGL
bool
-config BR2_PACKAGE_PROVIDES_OPENGL_EGL
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+config BR2_PACKAGE_PROVIDES_LIBEGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
string
diff --git a/package/opengl/libegl/libegl.mk b/package/opengl/libegl/libegl.mk
index 3311e5010..2e399cef6 100644
--- a/package/opengl/libegl/libegl.mk
+++ b/package/opengl/libegl/libegl.mk
@@ -5,9 +5,9 @@
################################################################################
LIBEGL_SOURCE =
-LIBEGL_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_OPENGL_EGL))
+LIBEGL_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_LIBEGL))
-ifeq ($(BR2_PACKAGE_HAS_OPENGL_EGL),y)
+ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
ifeq ($(LIBEGL_DEPENDENCIES),)
$(error No libEGL implementation selected. Configuration error.)
endif