summaryrefslogtreecommitdiff
path: root/package/openvmtools/openvmtools.mk
diff options
context:
space:
mode:
authorKaroly Kasza <kaszak@gmail.com>2015-03-29 18:59:20 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-07 22:39:41 +0200
commit54b6649cf7c84d39568d4e24d0b93ab6416c1075 (patch)
tree41ca305842b899cc41b86abdddcaaf34663856ca /package/openvmtools/openvmtools.mk
parent8ee6d5aa6acb9a1c4ece36ac65a6b92a213d47da (diff)
package/openvmtools: bump version to 9.10.0
[Thomas: - add explicit --with-ssl - remove comment above openssl condition, as it is obvious what is happening.] Signed-off-by: Karoly Kasza <kaszak@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openvmtools/openvmtools.mk')
-rw-r--r--package/openvmtools/openvmtools.mk37
1 files changed, 18 insertions, 19 deletions
diff --git a/package/openvmtools/openvmtools.mk b/package/openvmtools/openvmtools.mk
index f8230b2ca..f180f6f08 100644
--- a/package/openvmtools/openvmtools.mk
+++ b/package/openvmtools/openvmtools.mk
@@ -4,16 +4,19 @@
#
################################################################################
-OPENVMTOOLS_VERSION = 9.4.6-1770165
+OPENVMTOOLS_VERSION = 9.10.0-2476743
OPENVMTOOLS_SOURCE = open-vm-tools-$(OPENVMTOOLS_VERSION).tar.gz
-OPENVMTOOLS_SITE = http://downloads.sourceforge.net/project/open-vm-tools/open-vm-tools/stable-9.4.x
+OPENVMTOOLS_SITE = http://downloads.sourceforge.net/project/open-vm-tools/open-vm-tools/stable-9.10.0
OPENVMTOOLS_LICENSE = LGPLv2.1
OPENVMTOOLS_LICENSE_FILES = COPYING
-# Autoreconf needed because package is distributed without a configure script
-# See http://sourceforge.net/p/open-vm-tools/mailman/message/32550385/
+# Autoreconf needed or config/missing will run configure again at buildtime
OPENVMTOOLS_AUTORECONF = YES
-OPENVMTOOLS_CONF_OPTS = --without-icu --without-x --without-gtk2 --without-gtkmm --without-kernel-modules
-OPENVMTOOLS_DEPENDENCIES = libglib2
+OPENVMTOOLS_CONF_OPTS = --with-dnet \
+ --without-icu --without-x --without-gtk2 \
+ --without-gtkmm --without-kernel-modules \
+ --disable-deploypkg --without-xerces
+OPENVMTOOLS_CONF_ENV += CUSTOM_DNET_CPPFLAGS=" "
+OPENVMTOOLS_DEPENDENCIES = libglib2 libdnet
# When libfuse is available, openvmtools can build vmblock-fuse, so
# make sure that libfuse gets built first
@@ -21,26 +24,21 @@ ifeq ($(BR2_PACKAGE_LIBFUSE),y)
OPENVMTOOLS_DEPENDENCIES += libfuse
endif
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+OPENVMTOOLS_CONF_OPTS += --with-ssl
+OPENVMTOOLS_DEPENDENCIES += openssl
+else
+OPENVMTOOLS_CONF_OPTS += --without-ssl
+endif
+
ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PROCPS),y)
-# Set CUSTOM_PROCPS_LIBS to " " otherwise -L/lib is used by default.
-OPENVMTOOLS_CONF_ENV += CUSTOM_PROCPS_NAME=procps \
- CUSTOM_PROCPS_LIBS=" "
OPENVMTOOLS_CONF_OPTS += --with-procps
+OPENVMTOOLS_CONF_ENV += CUSTOM_PROCPS_NAME=procps
OPENVMTOOLS_DEPENDENCIES += procps-ng
else
OPENVMTOOLS_CONF_OPTS += --without-procps
endif
-ifeq ($(BR2_PACKAGE_OPENVMTOOLS_DNET),y)
-# Needed because if it is defined configure will
-# use a different method to check for dnet
-OPENVMTOOLS_CONF_ENV += CUSTOM_DNET_CPPFLAGS=" "
-OPENVMTOOLS_CONF_OPTS += --with-dnet
-OPENVMTOOLS_DEPENDENCIES += libdnet
-else
-OPENVMTOOLS_CONF_OPTS += --without-dnet
-endif
-
ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PAM),y)
OPENVMTOOLS_CONF_OPTS += --with-pam
OPENVMTOOLS_DEPENDENCIES += linux-pam
@@ -49,6 +47,7 @@ OPENVMTOOLS_CONF_OPTS += --without-pam
endif
# symlink needed by lib/system/systemLinux.c (or will cry in /var/log/messages)
+# defined in lib/misc/hostinfoPosix.c
# /sbin/shutdown needed for Guest OS restart/shutdown from hypervisor
define OPENVMTOOLS_POST_INSTALL_TARGET_THINGIES
ln -fs os-release $(TARGET_DIR)/etc/lfs-release