summaryrefslogtreecommitdiff
path: root/package/python/104-optional-tk.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-28 21:54:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-02 19:30:25 +0100
commit897d07c313104ddb54fcf9c538acb0ca65e1a687 (patch)
tree6a92eaeced471ff0029b54d00b86ede1c8c4a18f /package/python/104-optional-tk.patch
parent9badea2d058a75182f2a37bbefa0aaf48020575d (diff)
python: rename patches to the new convention
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/python/104-optional-tk.patch')
-rw-r--r--package/python/104-optional-tk.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/package/python/104-optional-tk.patch b/package/python/104-optional-tk.patch
new file mode 100644
index 000000000..f402e420f
--- /dev/null
+++ b/package/python/104-optional-tk.patch
@@ -0,0 +1,66 @@
+Add an option to disable the tk module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+
+---
+ Makefile.pre.in | 14 ++++++++++----
+ configure.in | 9 +++++++++
+ 2 files changed, 19 insertions(+), 4 deletions(-)
+
+Index: b/Makefile.pre.in
+===================================================================
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -960,7 +960,7 @@
+ plat-mac/lib-scriptpackages/SystemEvents \
+ plat-mac/lib-scriptpackages/Terminal
+ PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
+-LIBSUBDIRS= lib-tk site-packages \
++LIBSUBDIRS= site-packages \
+ encodings compiler hotshot \
+ email email/mime \
+ ensurepip ensurepip/_bundled \
+@@ -974,8 +974,7 @@
+ lib-old \
+ curses $(MACHDEPS)
+
+-TESTSUBDIRS = lib-tk/test lib-tk/test/test_tkinter \
+- lib-tk/test/test_ttk test test/audiodata test/capath test/data \
++TESTSUBDIRS = test test/audiodata test/capath test/data \
+ test/cjkencodings test/decimaltestdata test/xmltestdata \
+ test/imghdrdata \
+ test/subprocessdata \
+@@ -1009,6 +1008,12 @@
+ TESTSUBDIRS += sqlite3/test
+ endif
+
++ifeq (@TK@,yes)
++LIBSUBDIRS += lib-tk
++TESTSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
++ lib-tk/test/test_ttk
++endif
++
+ libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
+ @for i in $(SCRIPTDIR) $(LIBDEST); \
+ do \
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2636,6 +2636,15 @@
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
+ fi
+
++AC_SUBST(TK)
++AC_ARG_ENABLE(tk,
++ AS_HELP_STRING([--disable-tk], [disable tk]),
++ [ TK="${enableval}" ], [ TK=yes ])
++
++if test "$TK" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
++fi
++
+ AC_SUBST(PYDOC)
+
+ AC_ARG_ENABLE(pydoc,