summaryrefslogtreecommitdiff
path: root/package/stress-ng
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-09-09 11:53:47 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-09-09 23:14:42 +0200
commitc7efe2bed527b3e346f0dcdaf306981d6ce0ba60 (patch)
tree7a7be6bb248aa51491e8edb34cac2d98bc3baec4 /package/stress-ng
parent7244dea0a5ca788c9382a226651145cb240c30ae (diff)
package/stress-ng: new package
[Peter: license is GPLv2+] Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/stress-ng')
-rw-r--r--package/stress-ng/Config.in25
-rw-r--r--package/stress-ng/stress-ng.hash2
-rw-r--r--package/stress-ng/stress-ng.mk22
3 files changed, 49 insertions, 0 deletions
diff --git a/package/stress-ng/Config.in b/package/stress-ng/Config.in
new file mode 100644
index 000000000..cdf9984ca
--- /dev/null
+++ b/package/stress-ng/Config.in
@@ -0,0 +1,25 @@
+config BR2_PACKAGE_STRESS_NG
+ bool "stress-ng"
+ depends on BR2_USE_MMU # fork()
+ # disabled on musl: stress-malloc.c needs mallopt() and M_MMAP_THRESHOLD
+ # disabled on uClibc: stress-aio.c needs aio.h
+ depends on BR2_TOOLCHAIN_USES_GLIBC
+ # perf.c needs PERF_COUNT_HW_STALLED_CYCLES_FRONTEND
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
+ depends on !BR2_microblaze # keyutils
+ depends on !BR2_STATIC_LIBS # keyutils
+ select BR2_PACKAGE_KEYUTILS # stress-key.c needs keyutils.h
+ select BR2_PACKAGE_ATTR # stress-xattr.c needs xattr.h
+ help
+ stress-ng will stress test a computer system in various
+ selectable ways. It was designed to exercise various physical
+ subsystems of a computer as well as the various operating
+ system kernel interfaces.
+
+ http://kernel.ubuntu.com/~cking/stress-ng/
+
+comment "stress-ng needs a glibc toolchain w/ dynamic library, headers >= 3.0"
+ depends on !BR2_microblaze
+ depends on BR2_USE_MMU
+ depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 \
+ || !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/stress-ng/stress-ng.hash b/package/stress-ng/stress-ng.hash
new file mode 100644
index 000000000..497930397
--- /dev/null
+++ b/package/stress-ng/stress-ng.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 9d17dffafdf8dd71eb5c191973b65d4eb2964ecc31f1d01ad188fd03a0c49f6c stress-ng-0.04.16.tar.gz
diff --git a/package/stress-ng/stress-ng.mk b/package/stress-ng/stress-ng.mk
new file mode 100644
index 000000000..7169c2bdd
--- /dev/null
+++ b/package/stress-ng/stress-ng.mk
@@ -0,0 +1,22 @@
+################################################################################
+#
+# stress-ng
+#
+################################################################################
+
+STRESS_NG_VERSION = 0.04.16
+STRESS_NG_SITE = http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
+STRESS_NG_LICENSE = GPLv2+
+STRESS_NG_LICENSE_FILES = COPYING
+
+STRESS_NG_DEPENDENCIES = attr keyutils
+
+define STRESS_NG_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define STRESS_NG_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))