summaryrefslogtreecommitdiff
path: root/package/tcpreplay
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-06-19 07:26:48 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-06-19 13:19:37 +0200
commitb117ba41f1396f9aa5ee28dac8519ff6613cfd56 (patch)
tree764e0376e58db9fce594393142be5c8ffbd2570e /package/tcpreplay
parent39e4bf8abba9c9d2f308019b029ced1faa2f9350 (diff)
tcpreplay: use pcap-config
Since other libs can be pulled in by libpcap switch to using pcap-config, it's the correct way and simpler. Fixes: http://autobuild.buildroot.net/results/c02/c023bacd35e9ef1addeb881cd3d572f97f9b4b56/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/tcpreplay')
-rw-r--r--package/tcpreplay/tcpreplay.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/tcpreplay/tcpreplay.mk b/package/tcpreplay/tcpreplay.mk
index 2ee224e22..0f2f2e6bd 100644
--- a/package/tcpreplay/tcpreplay.mk
+++ b/package/tcpreplay/tcpreplay.mk
@@ -15,10 +15,8 @@ TCPREPLAY_CONF_ENV = \
TCPREPLAY_CONF_OPT = --with-libpcap=$(STAGING_DIR)/usr
TCPREPLAY_DEPENDENCIES = libpcap
-# libpcap may depend on symbols in libdbus-1 and libusb as well
-TCPREPLAY_LIBS = -lpcap \
- $(if $(BR2_PACKAGE_DBUS),-ldbus-1) \
- $(if $(BR2_PACKAGE_LIBUSB),-lusb-1.0)
+# libpcap may depend on symbols in other libs
+TCPREPLAY_LIBS = $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --libs)
TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close='$(TCPREPLAY_LIBS)' \
LIBS="$(TCPREPLAY_LIBS)"