summaryrefslogtreecommitdiff
path: root/package/tinyxml2
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-04-01 20:35:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-21 23:37:04 +0200
commit7e5a97eb965d922675b264acd1cc480ca70a79b3 (patch)
tree506f5a4db99b6dbb4445265271aabccc28aa1545 /package/tinyxml2
parent0ac0a812725a8458d717229dee312b099dae5cbf (diff)
package/tinyxml2: new package
Required for upcoming kodi-pvr-dvblink package: https://github.com/kodi-pvr/pvr.dvblink/blob/master/CMakeLists.txt#L11 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tinyxml2')
-rw-r--r--package/tinyxml2/Config.in11
-rw-r--r--package/tinyxml2/tinyxml2.mk13
2 files changed, 24 insertions, 0 deletions
diff --git a/package/tinyxml2/Config.in b/package/tinyxml2/Config.in
new file mode 100644
index 000000000..25bc5941a
--- /dev/null
+++ b/package/tinyxml2/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_TINYXML2
+ bool "tinyxml2"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ TinyXML-2 is a simple, small, efficient, C++ XML parser that can be
+ easily integrating into other programs.
+
+ http://www.grinninglizard.com/tinyxml2/index.html
+
+comment "tinyxml2 needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/tinyxml2/tinyxml2.mk b/package/tinyxml2/tinyxml2.mk
new file mode 100644
index 000000000..370049b91
--- /dev/null
+++ b/package/tinyxml2/tinyxml2.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# tinyxml2
+#
+################################################################################
+
+TINYXML2_VERSION = 2.2.0
+TINYXML2_SITE = $(call github,leethomason,tinyxml2,$(TINYXML2_VERSION))
+TINYXML2_LICENSE = zlib
+TINYXML2_LICENSE_FILES = readme.md
+TINYXML2_INSTALL_STAGING = YES
+
+$(eval $(cmake-package))