summaryrefslogtreecommitdiff
path: root/package/wpa_supplicant/wpa_supplicant.mk
diff options
context:
space:
mode:
authorMike Williams <mike@mikebwilliams.com>2015-03-20 15:14:15 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-20 20:43:11 +0100
commit1c74c8431341006d063f40b7436cc529d4378ae2 (patch)
tree638da5d4d588bcc4a48fffa856d847b710c110e1 /package/wpa_supplicant/wpa_supplicant.mk
parentaf17811662595ad1db0a992a3a7446c79d40d578 (diff)
wpa_supplicant: install systemd service files
Unlike other systemd services, these are not enabled by default, as the most likely configuration is that they will be managed by something like NetworkManager. Signed-off-by: Mike Williams <mike@mikebwilliams.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/wpa_supplicant/wpa_supplicant.mk')
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 5a81a9158..4b2ec164d 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -165,4 +165,15 @@ define WPA_SUPPLICANT_INSTALL_TARGET_CMDS
$(WPA_SUPPLICANT_INSTALL_DBUS)
endef
+define WPA_SUPPLICANT_INSTALL_INIT_SYSTEMD
+ $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant.service
+ $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant@.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant@.service
+ $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant-nl80211@.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-nl80211@.service
+ $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant-wired@.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-wired@.service
+endef
+
$(eval $(generic-package))