summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2014-12-09 11:51:21 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-09 20:19:58 +0100
commit301102e136c43545b5fff09a1f2fe8debf970064 (patch)
treef30981155561ed653031a6db84c1209b72ee569c /package
parent41d6f177d226b9014f5a14d0d05ca843f482d94f (diff)
slang: use specific build and install commands for static builds
Doing this we ensure that only the static library and a static version of slsh are built. Fixes: http://autobuild.buildroot.net/results/f12/f124ca3737baf5aca32029226805133d3544715c/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Markos Chandras <Markos.Chandras@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/slang/slang.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/slang/slang.mk b/package/slang/slang.mk
index 15b65b363..4dc9ad753 100644
--- a/package/slang/slang.mk
+++ b/package/slang/slang.mk
@@ -48,4 +48,10 @@ ifeq ($(BR2_PACKAGE_READLINE),y)
SLANG_DEPENDENCIES += readline
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ SLANG_MAKE_OPTS = static
+ SLANG_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-static
+ SLANG_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-static
+endif
+
$(eval $(autotools-package))