summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorMartin Bark <martin@barkynet.com>2016-06-16 18:15:38 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-18 15:37:47 +0200
commit4a34ac240cd0f051cfe189125cc70c368b1774fe (patch)
treebc0acf9372ba64747edc32b2756c26673094a707 /package
parent80899ff982b5645839e6f00021276c69c531f9df (diff)
package/bluez5_utils: correct systemd service install
Commit d732fa4 add the BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD rule, however, it is not correct. The [Install] section of bluetooth.service is as follows: [Install] WantedBy=bluetooth.target Alias=dbus-org.bluez.service hence there are currently two mistakes: 1) bluetooth.service is wanted by bluetooth.target not multi-user.target 2) dbus-org.bluez.service is a missing alias to bluetooth.service This commit fixes both these issues. Signed-off-by: Martin Bark <martin@barkynet.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/bluez5_utils/bluez5_utils.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/bluez5_utils/bluez5_utils.mk b/package/bluez5_utils/bluez5_utils.mk
index ddc8c452e..49cc7c217 100644
--- a/package/bluez5_utils/bluez5_utils.mk
+++ b/package/bluez5_utils/bluez5_utils.mk
@@ -77,9 +77,11 @@ BLUEZ5_UTILS_CONF_OPTS += --disable-systemd
endif
define BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD
- mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/
+ mkdir -p $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants
ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
- $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/bluetooth.service
+ $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants/bluetooth.service
+ ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
+ $(TARGET_DIR)/etc/systemd/system/dbus-org.bluez.service
endef
$(eval $(autotools-package))