summaryrefslogtreecommitdiff
path: root/support/scripts/apply-patches.sh
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-09-16 22:42:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-16 22:51:40 +0200
commit8d22c1bab7a36f636171ba263deb80fed86298b1 (patch)
treee88fe143c75bf9f9c251b372ed0eee69fd892baf /support/scripts/apply-patches.sh
parent0b9676b6913fad483601e5bc86ccfb78272d0241 (diff)
apply-patches.sh: Go back to only warn about unsupported file types
Fixes http://autobuild.buildroot.net/results/868/8687be8ec029486d9c5e2224cde542134f72884b/ The recent (d245fbb41dc: apply-patches.sh: detect missing patches) change to apply-patches.sh causes a number of regressions with packages using downloadable tarballs of patches (typically from Debian), as those contain additional files besides just the patches (ChangeLog's, debian/rules, ..). This use case is arguably abusing the _PATCH handling, but it used to work so people might rely on it so go back to only warn about this instead of erroring out. At the same time reword the warning message. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/scripts/apply-patches.sh')
-rwxr-xr-xsupport/scripts/apply-patches.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/support/scripts/apply-patches.sh b/support/scripts/apply-patches.sh
index 656aa716c..1ebaea990 100755
--- a/support/scripts/apply-patches.sh
+++ b/support/scripts/apply-patches.sh
@@ -73,8 +73,8 @@ function apply_patch {
*.patch*)
type="patch"; uncomp="cat"; ;;
*)
- echo "Unsupported format file for ${path}/${patch}";
- exit 1;
+ echo "Unsupported file type for ${path}/${patch}, skipping";
+ return 0
;;
esac
echo ""