summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-10-22 16:36:18 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-10-25 01:24:11 +0200
commitbcb835b042d385bac801e00cff2f1dbacff93629 (patch)
tree14157f1bcfffeed2365e2eb58ef07f084e0789c2 /system
parentbb6fae779128bbff042464b18b6a4a1d50de2d99 (diff)
system/inittab: update to fix bug #7442
Update inittabs (skeleton/busybox & sysvinit) to remove the trailing REMOUNT_ROOTFS_RW comment used as magic string in system/system.mk to enable/disable remounting the root filesystem rw or not since it affects sysvinit in doing so properly as reported in bug #7442. Instead update the sed expressions to match clean non-commented strings by searching for "-o remount,rw /" and checking that's the end of the line as well to avoid affecting possibly other remounts that a user can have in a custom inittab. Long-term the startup block of inittab should just move to a S00sysinit script or similar so that rcS can pick it up directly. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'system')
-rw-r--r--system/skeleton/etc/inittab2
-rw-r--r--system/system.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/system/skeleton/etc/inittab b/system/skeleton/etc/inittab
index 85881f460..99d84e4cc 100644
--- a/system/skeleton/etc/inittab
+++ b/system/skeleton/etc/inittab
@@ -15,7 +15,7 @@
# Startup the system
null::sysinit:/bin/mount -t proc proc /proc
-null::sysinit:/bin/mount -o remount,rw / # REMOUNT_ROOTFS_RW
+null::sysinit:/bin/mount -o remount,rw /
null::sysinit:/bin/mkdir -p /dev/pts
null::sysinit:/bin/mkdir -p /dev/shm
null::sysinit:/bin/mount -a
diff --git a/system/system.mk b/system/system.mk
index 5802e2d8f..e4a3160e5 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -79,12 +79,12 @@ endif
ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
# Find commented line, if any, and remove leading '#'s
define SYSTEM_REMOUNT_RW
- $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
+ $(SED) '/^#.*-o remount,rw \/$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
endef
else
# Find uncommented line, if any, and add a leading '#'
define SYSTEM_REMOUNT_RW
- $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
+ $(SED) '/^[^#].*-o remount,rw \/$$/s~^~#~' $(TARGET_DIR)/etc/inittab
endef
endif
TARGET_FINALIZE_HOOKS += SYSTEM_REMOUNT_RW