summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-16 10:03:17 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-16 15:13:57 +0200
commitd806005b08ec3228a252af4d2f038844a4d6fed2 (patch)
tree755f3b4551e16afce9b1b744c7a065d136c3d6aa /toolchain/toolchain-external
parent92cc924f2ebdfc9bc3d107400d7b3540801d90f6 (diff)
toolchain: remove the old BR2_VFP_FLOAT option
Now that we have a much better way of selecting between the various VFP versions and capabilities, the BR2_VFP_FLOAT version no longer makes sense. This commit gets rid of it, and adds the appropriate Config.in.legacy code. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/ext-tool.mk5
-rw-r--r--toolchain/toolchain-external/ext-toolchain-wrapper.c3
2 files changed, 0 insertions, 8 deletions
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 9d3dec417..67fc40d09 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -196,11 +196,6 @@ TOOLCHAIN_EXTERNAL_CFLAGS += -msoft-float
TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_SOFTFLOAT=1
endif
-ifeq ($(BR2_VFP_FLOAT),y)
-TOOLCHAIN_EXTERNAL_CFLAGS += -mfpu=vfp
-TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_VFPFLOAT=1
-endif
-
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
TOOLCHAIN_EXTERNAL_DEPENDENCIES = $(TOOLCHAIN_EXTERNAL_DIR)/.extracted
endif
diff --git a/toolchain/toolchain-external/ext-toolchain-wrapper.c b/toolchain/toolchain-external/ext-toolchain-wrapper.c
index f81aed493..afca6fab2 100644
--- a/toolchain/toolchain-external/ext-toolchain-wrapper.c
+++ b/toolchain/toolchain-external/ext-toolchain-wrapper.c
@@ -47,9 +47,6 @@ static char *predef_args[] = {
#ifdef BR_SOFTFLOAT
"-msoft-float",
#endif /* BR_SOFTFLOAT */
-#ifdef BR_VFPFLOAT
- "-mfpu=vfp",
-#endif /* BR_VFPFLOAT */
#ifdef BR_64
"-m64",
#endif