summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/pkg-download.mk6
-rwxr-xr-xsupport/download/git9
2 files changed, 7 insertions, 8 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index f6ed8be56..c86b9abcf 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -73,12 +73,6 @@ export BR_NO_CHECK_HASH_FOR =
# to get all the sources needed for one's build configuration.
################################################################################
-# Try a shallow clone - but that only works if the version is a ref (tag or
-# branch). Before trying to do a shallow clone we check if $($(PKG)_DL_VERSION)
-# is in the list provided by git ls-remote. If not we fall back on a full clone.
-#
-# Messages for the type of clone used are provided to ease debugging in case of
-# problems
define DOWNLOAD_GIT
$(EXTRA_ENV) $(DL_WRAPPER) -b git \
-o $(DL_DIR)/$($(PKG)_SOURCE) \
diff --git a/support/download/git b/support/download/git
index 73cbc0f7d..fd5f5392d 100755
--- a/support/download/git
+++ b/support/download/git
@@ -25,8 +25,13 @@ repo="${2}"
cset="${3}"
basename="${4}"
-# Try to see if we can do a shallow clone, since it is faster
-# than a full clone.
+# Try a shallow clone, since it is faster than a full clone - but that only
+# works if the version is a ref (tag or branch). Before trying to do a shallow
+# clone we check if ${cset} is in the list provided by git ls-remote. If not
+# we fall back on a full clone.
+#
+# Messages for the type of clone used are provided to ease debugging in case of
+# problems
git_done=0
if [ -n "$(${GIT} ls-remote "${repo}" "${cset}" 2>&1)" ]; then
printf "Doing shallow clone\n"