summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/pciutils/pciutils.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 350ca0d35..fd6f8aa57 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -65,4 +65,12 @@ define PCIUTILS_INSTALL_STAGING_CMDS
SHARED=$(PCIUTILS_SHARED) install install-lib
endef
+
+# Library lacks +x so strip skips it
+define PCIUTILS_FIX_LIBRARY_MODE
+ -chmod +x $(TARGET_DIR)/usr/lib/libpci.so*
+endef
+
+PCIUTILS_POST_INSTALL_TARGET_HOOKS += PCIUTILS_FIX_LIBRARY_MODE
+
$(eval $(generic-package))