summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index eee0dba23..66e728f79 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -71,7 +71,13 @@ UBOOT_BIN = u-boot.bin
UBOOT_BIN_IFT = $(UBOOT_BIN).ift
endif
+# The kernel calls AArch64 'arm64', but U-Boot calls it just 'arm', so
+# we have to special case it.
+ifeq ($(KERNEL_ARCH),arm64)
+UBOOT_ARCH = arm
+else
UBOOT_ARCH = $(KERNEL_ARCH)
+endif
UBOOT_MAKE_OPTS += \
CROSS_COMPILE="$(TARGET_CROSS)" \