summaryrefslogtreecommitdiff
path: root/package/avrdude/avrdude.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/avrdude/avrdude.mk')
-rw-r--r--package/avrdude/avrdude.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/avrdude/avrdude.mk b/package/avrdude/avrdude.mk
new file mode 100644
index 000000000..338d61c39
--- /dev/null
+++ b/package/avrdude/avrdude.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# avrdude
+#
+################################################################################
+
+AVRDUDE_VERSION = eabe067c4527bc2eedc5db9288ef5cf1818ec720
+AVRDUDE_SITE = $(call github,kcuzner,avrdude,$(AVRDUDE_VERSION))
+AVRDUDE_LICENSE = GPLv2+
+AVRDUDR_LICENSE_FILES = avrdude/COPYING
+AVRDUDE_SUBDIR = avrdude
+# Sources coming from git, without generated configure and Makefile.in
+# files.
+AVRDUDE_AUTORECONF = YES
+AVRDUDE_DEPENDENCIES = libelf libusb libusb-compat ncurses
+
+ifeq ($(BR2_PACKAGE_LIBFTDI),y)
+AVRDUDE_DEPENDENCIES += libftdi
+endif
+
+# if /etc/avrdude.conf exists, the installation process creates a
+# backup file, which we do not want in the context of Buildroot.
+define AVRDUDE_REMOVE_BACKUP_FILE
+ $(RM) -f $(TARGET_DIR)/etc/avrdude.conf.bak
+endef
+
+AVRDUDE_POST_INSTALL_TARGET_HOOKS += AVRDUDE_REMOVE_BACKUP_FILE
+
+$(eval $(autotools-package))
+