summaryrefslogtreecommitdiff
path: root/package/keyutils
diff options
context:
space:
mode:
Diffstat (limited to 'package/keyutils')
-rw-r--r--package/keyutils/Config.in6
-rw-r--r--package/keyutils/keyutils.mk4
2 files changed, 6 insertions, 4 deletions
diff --git a/package/keyutils/Config.in b/package/keyutils/Config.in
index fcb075fa9..6f0758f47 100644
--- a/package/keyutils/Config.in
+++ b/package/keyutils/Config.in
@@ -2,8 +2,14 @@ config BR2_PACKAGE_KEYUTILS
bool "keyutils"
depends on !BR2_microblaze
depends on BR2_USE_MMU # fork()
+ depends on !BR2_STATIC_LIBS # dlopen
help
These tools are used to control the key management system
built into the Linux kernel.
http://people.redhat.com/~dhowells/keyutils/
+
+comment "keyutils needs a toolchain w/ dynamic library"
+ depends on !BR2_microblaze
+ depends on BR2_USE_MMU
+ depends on BR2_STATIC_LIBS
diff --git a/package/keyutils/keyutils.mk b/package/keyutils/keyutils.mk
index 36588e6c3..3d6697eb9 100644
--- a/package/keyutils/keyutils.mk
+++ b/package/keyutils/keyutils.mk
@@ -19,10 +19,6 @@ KEYUTILS_MAKE_PARAMS = \
CPPFLAGS="$(TARGET_CPPFLAGS) -I." \
LNS="$(HOSTLN) -sf"
-ifeq ($(BR2_STATIC_LIBS),y)
-KEYUTILS_MAKE_PARAMS += NO_SOLIB=1
-endif
-
ifeq ($(BR2_SHARED_LIBS),y)
KEYUTILS_MAKE_PARAMS += NO_ARLIB=1
endif