summaryrefslogtreecommitdiff
path: root/package/openssh/openssh.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssh/openssh.mk')
-rw-r--r--package/openssh/openssh.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 60b65af33..f5f334ed0 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -4,7 +4,7 @@
#
################################################################################
-OPENSSH_VERSION = 6.4p1
+OPENSSH_VERSION = 6.5p1
OPENSSH_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable
OPENSSH_CONF_ENV = LD="$(TARGET_CC)" LDFLAGS="$(TARGET_CFLAGS)"
OPENSSH_CONF_OPT = --disable-lastlog --disable-utmp \
@@ -30,4 +30,14 @@ define OPENSSH_INSTALL_INIT_SYSV
$(TARGET_DIR)/etc/init.d/S50sshd
endef
+# Replace deprecated bcopy/bzero with memset/memcpy
+define OPENSSH_REPLACE_SUSV3_DEPRECATED
+ for src in `find $(@D) -name \*.c`; do \
+ $(SED) "s/bzero(\(.*,\)/memset(\1 0, /" $${src} ;\
+ $(SED) "s/bcopy(\(.*,\) \(.*,\)/memcpy(\2 \1/" $${src} ;\
+ done
+endef
+
+OPENSSH_POST_PATCH_HOOKS += OPENSSH_REPLACE_SUSV3_DEPRECATED
+
$(eval $(autotools-package))