summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2014-03-11 16:04:28 +0000
committerDaniel Vetter <daniel.vetter@ffwll.ch>2014-03-11 17:19:47 +0100
commit14ea2a04ebfa287e33b69a3bc7e47f02ba93c9ed (patch)
tree92979ef4b06e2e8cb61287076d364cfe76c43ddf /configure.ac
parentc769d0988b7fae0e758046ba165c9c52c4f2816a (diff)
Add API documentation support
Add optional support for building API documentation using gtk-doc. Signed-off-by: Thomas Wood <thomas.wood@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4aee793e..2c991a85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,14 @@ AC_PROG_CC
AM_PROG_LEX
AC_PROG_YACC
+# check for gtk-doc
+m4_ifdef([GTK_DOC_CHECK], [
+GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+],[
+AM_CONDITIONAL([ENABLE_GTK_DOC], false)
+])
+
+
# Checks for functions, headers, structures, etc.
AC_HEADER_STDC
AC_CHECK_HEADERS([termios.h])
@@ -192,6 +200,10 @@ AC_CONFIG_FILES([
Makefile
benchmarks/Makefile
demos/Makefile
+ docs/Makefile
+ docs/reference/Makefile
+ docs/reference/intel-gpu-tools/Makefile
+ docs/reference/intel-gpu-tools/version.xml
lib/Makefile
man/Makefile
scripts/Makefile