summaryrefslogtreecommitdiff
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2014-10-27 15:08:50 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2014-10-29 13:29:32 +0100
commit685e57736a2c5da2e955ffd2f0027e4b42e397f7 (patch)
tree73f67d671b29e59de413740f1f5e3c177199fbc9 /lib/tests/Makefile.am
parent9d6a2cacf6796c8e06e4b7432c5f795d4ee56d8b (diff)
Move library selftests to lib/tests
Again they're not really igt testcases so are in the way of running spatch unconditionally. Move them someplace else. Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
new file mode 100644
index 00000000..808d31f2
--- /dev/null
+++ b/lib/tests/Makefile.am
@@ -0,0 +1,18 @@
+include Makefile.sources
+
+EXTRA_PROGRAMS = $(TESTS_testsuite)
+EXTRA_DIST = $(TESTS_scripts)
+
+CLEANFILES = $(EXTRA_PROGRAMS)
+
+AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
+ -I$(srcdir)/../.. \
+ -I$(srcdir)/.. \
+ -include "$(srcdir)/../../lib/check-ndebug.h" \
+ -DIGT_DATADIR=\""$(abs_srcdir)"\" \
+ $(NULL)
+
+LDADD = ../libintel_tools.la $(PCIACCESS_LIBS) $(DRM_LIBS)
+
+LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS)
+AM_CFLAGS += $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) $(GLIB_CFLAGS)