summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTim Gore <tim.gore@intel.com>2015-04-01 16:36:59 +0100
committerThomas Wood <thomas.wood@intel.com>2015-04-02 16:35:42 +0100
commitebb46bb2e2138b5f864a3fdff21d013d03e7931f (patch)
tree9ea6ac46f1b6ebccdf8712ab9f1d035f286fd35a /tests/Makefile.am
parenta95033fdbcf32ea64ad2b75f38315489ee1c2042 (diff)
tests/gem_concurrent.c: rename to gem_concurrent_all
Recent patch #7763349a9a87.. renamed gem_concurrent_blit.c to gem_concurrent.c and then added entries to Makefile.am to make two identical executeables (but with different names) from this source file. This executeable changes its behaviour based on argv[0]. But, this has broken the Android build, which does not use autotools. This patch instead renames the source file to match the name of one executable (gem_concurrent_all.c) and creates a second source file which simply #includes the first. The Makefile.am entries are also removed. This restores the simple test.c -> test executeable relationship seen in the rest of IGT and allows the Android build system to work without parsing Makfile.am or having to incorporate a special workaround for this test. Signed-off-by: Tim Gore <tim.gore@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk> Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 69c7c4e0..7fbf6221 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -69,8 +69,6 @@ gem_ctx_basic_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_ctx_basic_LDADD = $(LDADD) -lpthread
gem_ctx_thrash_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_ctx_thrash_LDADD = $(LDADD) -lpthread
-gem_concurrent_all_SOURCES = gem_concurrent.c
-gem_concurrent_blit_SOURCES = gem_concurrent.c
gem_fence_thrash_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_fence_thrash_LDADD = $(LDADD) -lpthread
gem_fence_upload_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)