summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRamalingam C <ramalingam.c@intel.com>2019-11-29 16:54:11 +0530
committerChris Wilson <chris@chris-wilson.co.uk>2019-11-29 14:07:35 +0000
commit187bef1ee5aa861d3d0f2a2edfe3b6df6909ebb2 (patch)
tree426014c2f34f9d15380cb96ed2cd8278ef97305b /tests/Makefile.am
parent38eba9696fe7573e53d854311d6b1b55195df426 (diff)
tests/dumb_buffer: Tests for creation and map
Dumb buffer creation and mapping are covered with test cases. v2: Made as a generic test for dumb buffer creation [Chris] v3: dumb_map is used [Chris] Added two tests for map. Signed-off-by: Ramalingam C <ramalingam.c@intel.com> Cc: Chris Wilson <chris@chris-wilson.co.uk> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fe60b78..4d712c1b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -89,6 +89,8 @@ AM_LDFLAGS = -Wl,--as-needed
drm_import_export_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
drm_import_export_LDADD = $(LDADD) -lpthread
+dumb_buffer_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
+dumb_buffer_LDADD = $(LDADD) -lpthread -latomic
gem_create_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_create_LDADD = $(LDADD) -lpthread -latomic
gem_close_race_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)