summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2020-02-18 20:16:56 +0200
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2020-02-21 17:20:14 +0200
commit5f7e4ae6a91ed2c104593b8abd5b71a6cc96fc10 (patch)
tree1d2eca8bb2bbeefd6f20cf8f44e2bcbaa92dbd1e /tests/Makefile.am
parent3e686098d928aa928f668e00fa01e92234e173ff (diff)
tests/perf: reuse the new i915-perf library
Now that most configs are stored inside IGT along with their uuid, we can just source the correct one for that internal library. Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Acked-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 87ffec2e..8219e79b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -130,6 +130,7 @@ prime_self_import_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
prime_self_import_LDADD = $(LDADD) -lpthread
gem_userptr_blits_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_userptr_blits_LDADD = $(LDADD) -lpthread
+perf_LDADD = $(LDADD) $(top_builddir)/lib/libi915_perf.la
perf_pmu_LDADD = $(LDADD) $(top_builddir)/lib/libigt_perf.la
sw_sync_LDADD = $(LDADD) -latomic