summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorJanusz Krzysztofik <janusz.krzysztofik@linux.intel.com>2021-04-07 14:29:54 +0200
committerJanusz Krzysztofik <janusz.krzysztofik@linux.intel.com>2021-04-14 17:51:15 +0200
commit870601e7fb4aa8dcb118fd99833d07ce3dd2ea88 (patch)
tree1403ce6f603ee969809b10f6424fdf341d1249e6 /tests/meson.build
parentac9dc8487c1d73ad5327737297f0777e6bd2accf (diff)
tests/core_hotunplug: Add perf health check
Sometimes CI reports skips of perf subtests when run subsequently after core_hotunplug. That may be an indication of issues with restoring device perf features on driver (hot)rebind. Detect device perf support at test start and check if still available after driver rebind. If that fails, a post-subtest device recovery step restores the device perf support so no subsequently executed tests are affected. Signed-off-by: Janusz Krzysztofik <janusz.krzysztofik@linux.intel.com> Acked-by: Marcin Bernatowicz <marcin.bernatowicz@linux.intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6ad34409..19cc4ebe 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -3,7 +3,6 @@ test_progs = [
'core_getclient',
'core_getstats',
'core_getversion',
- 'core_hotunplug',
'core_setmaster',
'core_setmaster_vs_auth',
'debugfs_test',
@@ -362,6 +361,13 @@ test_executables += executable('perf',
install : true)
test_list += 'perf'
+test_executables += executable('core_hotunplug', 'core_hotunplug.c',
+ dependencies : test_deps + [ lib_igt_i915_perf ],
+ install_dir : libexecdir,
+ install_rpath : libexecdir_rpathdir,
+ install : true)
+test_list += 'core_hotunplug'
+
executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
dependencies : test_deps,
install_dir : libexecdir,