summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorKarthik B S <karthik.b.s@intel.com>2020-04-28 15:38:32 +0530
committerKunal Joshi <kunal1.joshi@intel.com>2020-05-06 03:11:43 +0530
commite83abfca61d407d12eee4d25bb0e8686337a7791 (patch)
tree709c436e7c8496a80aaa3062c0c3f7b94840dc8c /tests/meson.build
parent3cff0b137bcb2f6b329a6cb0fc03962d8cc65117 (diff)
tests/kms_multipipe_modeset: Add test to validate max pipe configuration
Added test to validate max pipe configuration for a platform. In the test, the reference CRC is collected first by doing modeset on all the outputs individually.Then a simultaneous modeset is done on all the outputs and the CRC is collected. This is compared with the reference CRC. If the number of outputs connected is less than the number of pipes supported by the platform, then the test skips. This test is added to verify if the max pipe configuration for a given platform is working fine. Even though there are other tests which test multipipe configuration, they test some other functionalities as well together with multipipe. This is a stand alone test that intends to only verify simultaneous modeset at the max pipe configuration. v2: -Fix Typo in comment (Petri) -Use igt_require_pipe_crc() to prevent crash in non i915 case (Petri) -Print the number of outputs and pipes in igt_require() for debugging aid (Petri) v3: -Change the subtest name (Petri) -Avoid multiple loops and remove the output_to_pipe variable, by making the output to pipe mapping fixed (Ankit) Signed-off-by: Karthik B S <karthik.b.s@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Ankit Nautiyal <ankit.k.nautiyal@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 0bdcfbe4..88e4875b 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -45,6 +45,7 @@ test_progs = [
'kms_lease',
'kms_legacy_colorkey',
'kms_mmap_write_crc',
+ 'kms_multipipe_modeset',
'kms_panel_fitting',
'kms_pipe_b_c_ivb',
'kms_pipe_crc_basic',