summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 4dd5a9c9..6feaafe3 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -255,13 +255,19 @@ if alsa.found() and gsl.found()
test_deps += alsa
endif
+libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-gpu-tools')
+
foreach prog : test_progs
executable(prog, prog + '.c',
- dependencies : test_deps)
+ dependencies : test_deps,
+ install_dir : libexecdir,
+ install : true)
endforeach
executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
- dependencies : test_deps)
+ dependencies : test_deps,
+ install_dir : libexecdir,
+ install : true)
test_progs += 'testdisplay'
run_command('generate_testlist.sh', test_progs)