summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2017-02-09 11:29:52 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-02-09 15:02:12 +0100
commit125dd2d1198a5ba25b1865d58ef649cfa5c4e84f (patch)
tree1dcd701e1aa69e595fedc8e5141655c4d9882e04
parent1de31b0a67fac403944fe26897d0b0cf0b24f7d5 (diff)
libevent: drop openssl static linking workaround
Commit f29bb169cf (libevent: fix openssl detection when statically linking) forced libevent to link against zlib when statically linking against openssl as the configure script failed to do this. Since then libevent has been bumped, and it now uses pkg-config to figure out how to link with openssl, so ensure pkg-config is available and drop the now-unneeded workaround. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/libevent/libevent.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/package/libevent/libevent.mk b/package/libevent/libevent.mk
index 128bb2ac7..5458ce316 100644
--- a/package/libevent/libevent.mk
+++ b/package/libevent/libevent.mk
@@ -24,13 +24,8 @@ LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
-LIBEVENT_DEPENDENCIES += openssl
+LIBEVENT_DEPENDENCIES += host-pkgconf openssl
LIBEVENT_CONF_OPTS += --enable-openssl
-# openssl needs zlib but configure forgets to link against it causing
-# openssl detection to fail
-ifeq ($(BR2_STATIC_LIBS),y)
-LIBEVENT_CONF_ENV += OPENSSL_LIBADD='-lz'
-endif
else
LIBEVENT_CONF_OPTS += --disable-openssl
endif