summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2017-02-14 10:01:32 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-02-14 11:15:28 +0100
commit5c4d3560b94c9cb8f1594c9200a632b89ddf7aa0 (patch)
tree2ae7cf9d401b518723e273bd8d51912475457e3f
parent8b8b4f7bfe50a33bbda9ed0cbbdc5170c3147625 (diff)
bctoolbox: fix typos and logic error
To get the directory path from the library name you need to use a single filename. Fix typo in variable name. This fixes the ortp autobuild errors which uses the broken pkgconfig file from bctoolbox. Fixes: http://autobuild.buildroot.net/results/37d5625df4be11ccdc063871e9f6e13d5f59fb52 http://autobuild.buildroot.net/results/1999c841fae41f860f00747a362327cb2857e687 Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/bctoolbox/0001-fix-typo.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/bctoolbox/0001-fix-typo.patch b/package/bctoolbox/0001-fix-typo.patch
new file mode 100644
index 000000000..b94daee8d
--- /dev/null
+++ b/package/bctoolbox/0001-fix-typo.patch
@@ -0,0 +1,18 @@
+Fix a typo in the variable name. Only check path for a single library name.
+
+Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
+
+diff -Nur bctoolbox-0.4.0.orig/CMakeLists.txt bctoolbox-0.4.0/CMakeLists.txt
+--- bctoolbox-0.4.0.orig/CMakeLists.txt 2016-10-06 17:30:41.000000000 +0200
++++ bctoolbox-0.4.0/CMakeLists.txt 2017-02-13 23:30:38.641288032 +0100
+@@ -103,8 +103,8 @@
+ endif()
+
+ if(MBEDTLS_FOUND)
+- get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARIES}" PATH)
+- set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedlts_library_path}")
++ get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARY}" PATH)
++ set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedtls_library_path}")
+ endif()
+ if(POLARSSL_FOUND)
+ get_filename_component(polarssl_library_path "${POLARSSL_LIBRARIES}" PATH)