summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2017-02-12 22:15:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-15 22:11:11 +0100
commit77941272f41c484a71c2a76be285a514ed518957 (patch)
tree9caf74645d74bc24b114bef6c03adb49b38e09f5
parentf165032e4f01aa46b43cc8136bac1c5b47aa8545 (diff)
ed: use generic extract command
The generic code now knows how to extract .tar.lz archives. Remove the local extract code. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/ed/ed.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/package/ed/ed.mk b/package/ed/ed.mk
index 50adeb4ec..6b9f65ec5 100644
--- a/package/ed/ed.mk
+++ b/package/ed/ed.mk
@@ -10,15 +10,9 @@ ED_SOURCE = ed-$(ED_VERSION).tar.lz
ED_CONF_OPTS = \
CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)"
-ED_DEPENDENCIES = host-lzip
ED_LICENSE = GPLv3+
ED_LICENSE_FILES = COPYING
-define ED_EXTRACT_CMDS
- $(HOST_DIR)/usr/bin/lzip -d -c $(DL_DIR)/$(ED_SOURCE) | \
- tar --strip-components=1 -C $(@D) $(TAR_OPTIONS) -
-endef
-
define ED_CONFIGURE_CMDS
(cd $(@D); \
$(TARGET_MAKE_ENV) ./configure \