summaryrefslogtreecommitdiff
path: root/Makefile.legacy
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2014-02-04 16:18:52 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-09 17:00:13 +0100
commit4113b3c3bdb9c7943e011827982000403f66dc61 (patch)
treef4d52eb74841c6f925ca0a200f7cd0fc9fce454c /Makefile.legacy
parenta7c1b84a5967e88be8032ef085c2d84aafc0008a (diff)
infra: replace BUILDROOT_CONFIG with BR2_CONFIG
To make the naming consistent (all user-visible options should be prefixed with BR2_). An entry is added to Makefile.legacy to warn users who have set BUILDROOT_CONFIG but not BR2_CONFIG. Still export BUILDROOT_CONFIG but pointing to some phony value, to make sure that scripts that still use it fail in a predictable way. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Jérémy Rosen <jeremy.rosen@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile.legacy')
-rw-r--r--Makefile.legacy12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.legacy b/Makefile.legacy
index 4954398c5..ea18bc615 100644
--- a/Makefile.legacy
+++ b/Makefile.legacy
@@ -28,6 +28,18 @@ $(error "The BUILDROOT_DL_DIR environment variable was renamed to BR2_DL_DIR.")
endif
endif
+# Similar to above for BUILDROOT_CONFIG, but here we have no .config equivalent.
+ifneq ($(BUILDROOT_CONFIG),)
+ifneq ($(BUILDROOT_CONFIG),$(BR2_CONFIG))
+$(error "The BUILDROOT_CONFIG environment variable was renamed to BR2_CONFIG.")
+endif
+endif
+
+# If a script is using the deprecated BUILDROOT_CONFIG, make sure it fails.
+# Add some directories in front just in case someone used dirname on it.
+BUILDROOT_CONFIG = /tmp/deprecated/The-BUILDROOT_CONFIG-environment-variable-was-renamed-to-BR2_CONFIG
+export BUILDROOT_CONFIG
+
#
# Legacy options from 2012.08
#