summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2016-11-22 21:23:02 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-23 23:29:45 +0100
commit171d4103c565d618ac6dfc61dedf3e1a310e8d6c (patch)
tree7b2621e9ce08ae53564737e5283f003b65fb212a /Makefile
parent82f7217b334cc5e86ed81b62c3c184a44c813405 (diff)
Makefile: fix distclean removal of $(O)
The distclean target no longer removes the "output" directory for in-tree builds, because $(O) is no longer just "output" in that case. Change the test to be against "$(CURDIR)/output", to match the O setting, and a similar test elsewhere in the same Makefile. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 37e4bd4db..13239616a 100644
--- a/Makefile
+++ b/Makefile
@@ -928,7 +928,7 @@ clean:
$(LEGAL_INFO_DIR) $(GRAPHS_DIR)
distclean: clean
-ifeq ($(O),output)
+ifeq ($(O),$(CURDIR)/output)
rm -rf $(O)
endif
rm -rf $(TOPDIR)/dl $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \