summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-11-03 02:55:17 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-03 21:48:47 +0100
commit2048e22fa1fe2d5ff654e0fb6a17042254efc2a3 (patch)
treee4fbe2ac5d1eac994687d208a00ca5a3ef3d26fa /Makefile
parent5e3f89666bbe0bf493ade79ffa4ad3c863bf71b4 (diff)
core: remove redundant "override O := $(O)"
The top-level Makefile contains an "override O := $(O)" statement that is purportedly required to make sure the O flag doesn't leak into the environment of sub-makes. However, since commit 173135d, there is already an "override O := ..." a few lines down. Therefore, the first override is redundant. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 0 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 4b494a330..cb030d46c 100644
--- a/Makefile
+++ b/Makefile
@@ -34,13 +34,6 @@ SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
# build by preventing it from being forwarded to sub-make calls.
ifneq ("$(origin O)", "command line")
O := $(CURDIR)/output
-else
-# Strangely enough O is still passed to submakes with MAKEOVERRIDES
-# (with make 3.81 atleast), the only thing that changes is the output
-# of the origin function (command line -> environment).
-# Unfortunately some packages don't look at origin (E.G. uClibc 0.9.31+)
-# To really make O go away, we have to override it.
-override O := $(O)
endif
# Check if the current Buildroot execution meets all the pre-requisites.