summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRahul Jain <Rahul.Jain@imgtec.com>2016-11-15 16:33:20 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-15 22:43:23 +0100
commit472f0ae2dff7a912bebdb025f7dca0541ebc9769 (patch)
treef38c98115a22371748a543da61dcec7bd4b5fcd3 /Makefile
parent6672a8a14194c75a886e2a9d3dcff3f8c2c74ccc (diff)
Makefile: add missing targets to noconfig_targets and nobuild_targets
currently some buildroot targets fails (list-defconfigs, graph-build, etc), if there is an issue with configuration. For example, enabling uboot package without providing custom version name results in failing of various targets. Signed-off-by: Rahul Jain <Rahul.Jain@imgtec.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> [Thomas: as suggested by Arnout, added printvars and savedefconfig to nobuild_targets.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 6cf5f1ce1..eff814b8c 100644
--- a/Makefile
+++ b/Makefile
@@ -126,7 +126,8 @@ export BR2_VERSION_FULL := $(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setlo
noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig allyesconfig allnoconfig silentoldconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
- print-version olddefconfig distclean
+ print-version olddefconfig distclean manual manual-html manual-split-html \
+ manual-pdf manual-text manual-epub
# Some global targets do not trigger a build, but are used to collect
# metadata, or do various checks. When such targets are triggered,
@@ -137,9 +138,12 @@ noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconf
# We're building in two situations: when MAKECMDGOALS is empty
# (default target is to build), or when MAKECMDGOALS contains
# something else than one of the nobuild_targets.
-nobuild_targets := source source-check \
- legal-info external-deps _external-deps \
- clean distclean help
+nobuild_targets := source %-source source-check \
+ legal-info %-legal-info external-deps _external-deps \
+ clean distclean help show-targets graph-depends \
+ %-graph-depends %-show-depends %-show-version \
+ graph-build graph-size list-defconfigs \
+ savedefconfig printvars
ifeq ($(MAKECMDGOALS),)
BR_BUILDING = y
else ifneq ($(filter-out $(nobuild_targets),$(MAKECMDGOALS)),)