summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-10-14 16:39:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-10-16 13:01:02 +0200
commit49117c1028033b80394eb1d0ef3d58009151ca8d (patch)
tree33ec9831705a70318ff299ee2bf9fafa3c3b3d15 /Makefile
parent339e1c9500cd1057118576c51be4953c23bc7a40 (diff)
core: support description for br2-external trees
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c8f1fece9..a86021874 100644
--- a/Makefile
+++ b/Makefile
@@ -980,7 +980,7 @@ define list-defconfigs
[ -f "$${defconfig}" ] || continue; \
if $${first}; then \
if [ "$(2)" ]; then \
- printf "External configs in $(2):\n"; \
+ printf 'External configs in "$(call qstrip,$(2))":\n'; \
else \
printf "Built-in configs:\n"; \
fi; \
@@ -997,7 +997,8 @@ endef
list-defconfigs:
$(call list-defconfigs,$(TOPDIR))
$(foreach name,$(BR2_EXTERNAL_NAMES),\
- $(call list-defconfigs,$(BR2_EXTERNAL_$(name)_PATH),$(name))$(sep))
+ $(call list-defconfigs,$(BR2_EXTERNAL_$(name)_PATH),\
+ $(BR2_EXTERNAL_$(name)_DESC))$(sep))
release: OUT = buildroot-$(BR2_VERSION)