summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-10-15 16:51:07 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-10-15 23:14:45 +0200
commit49315f2fac540b53125b46df341f7d815bbb95cd (patch)
treecd758b69de5bcc3736b9bfc6a18ba5ab480a2f78 /Makefile
parent3534399db48cfd066ff45a2bfa2ee0998024a9ab (diff)
Remove BR2_DEPRECATED
The BR2_DEPRECATED logic is a lot less useful than the legacy handling, because the symbols just disappears without warning to the user. For example, we had a few defconfigs that were using deprecated symbols (which were not actually used because BR2_DEPRECATED wasn't set) so these didn't build the expected code anymore. Also, the idea behind BR2_DEPRECATED is that you can easily revive it again if there is interest. However, it is relatively easy to revert the removal of a package as well. The deprecation is also more effort because it has to be removed twice: once when deprecating, and once when really removing. It doesn't make sense to add a legacy entry for BR2_DEPRECATED. Users who actually used it will get legacy warnings instead. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 74b831ead..411086186 100644
--- a/Makefile
+++ b/Makefile
@@ -436,9 +436,7 @@ all: world
# Include legacy before the other things, because package .mk files
# may rely on it.
-ifneq ($(BR2_DEPRECATED),y)
include Makefile.legacy
-endif
include package/Makefile.in
include support/dependencies/dependencies.mk