summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-11-05 22:05:08 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-05 23:34:26 +0100
commit6bb7430a20871ad4e3ccbc8c1992d60117214be2 (patch)
tree733cd1aca75de9d6e393fce7f2b7e99a5ffe4012 /Makefile
parentdbc5f228b219d9b05a048303ddbd624da3411dd2 (diff)
Makefile: delete default rules
We don't use the default implicit rules that are added by make, so they just slow down the Makefile processing. The default implicit rules can be removed by defining an empty .SUFFIXES: target. This speeds up the start of the build on my machine from 5.6s to 4.9s. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4ea64b369..6cf5f1ce1 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,9 @@
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
+# Delete default rules. We don't use them. This saves a bit of time.
+.SUFFIXES:
+
# we want bash as shell
SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
else if [ -x /bin/bash ]; then echo /bin/bash; \