summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2016-11-22 21:31:31 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-27 22:51:45 +0100
commit6caa76db22ad952f3fe6329da39defed060d8980 (patch)
tree53e3cb093e6c4025a64dd2e4bc547740aa95683a /Makefile
parentc2a79469b28f77d65bf44ca180493f26497f0bf5 (diff)
Makefile: drop redundant shell call when deriving BASE_DIR
Commit 173135df5b69dfd5ae6fe6cf2de8833c6f74c143 ("core: re-enter make if $(CURDIR) or $(O) are not canonical paths") introduced the CANONICAL_O variable, defined as: CANONICAL_O := $(shell mkdir -p $(O) >/dev/null 2>&1)$(realpath $(O)) This duplicates the definition of BASE_DIR, by different means: BASE_DIR := $(shell mkdir -p $(O) && cd $(O) >/dev/null && pwd) So one of these shell calls is redundant. CANONICAL_O is defined first, so this commit replaces the BASE_DIR derivation with $(CANONICAL_O). Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 4f6269faa..55d928de3 100644
--- a/Makefile
+++ b/Makefile
@@ -174,10 +174,10 @@ endif
# bash prints the name of the directory on 'cd <dir>' if CDPATH is
# set, so unset it here to not cause problems. Notice that the export
-# line doesn't affect the environment of $(shell ..) calls, so
-# explictly throw away any output from 'cd' here.
+# line doesn't affect the environment of $(shell ..) calls.
export CDPATH :=
-BASE_DIR := $(shell mkdir -p $(O) && cd $(O) >/dev/null && pwd)
+
+BASE_DIR := $(CANONICAL_O)
$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))