summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-05-07 18:14:36 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-24 16:56:50 +0200
commit7bfce06a4c6b4c2badeb52065c2184096031df9f (patch)
tree46c5021f2dd3ff955875d367d9d6fa7284f7afa4 /Makefile
parentd271f89b0823987b3fa4db83166692da928c69f6 (diff)
core/legal-info: generate a hash of all saved files
Having a hash of the saved files can be interesting for the recipient to verify the integrity of the files. We remove the warning file earlier, to exclude it from the hash list. We generate the hash list in a temporary file that will not be matched by the "find" expression, and once the file is generated, we remain it to its final name. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Tested-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> [Thomas: adjust indentation, improve commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 78b44c5e4..41f02745a 100644
--- a/Makefile
+++ b/Makefile
@@ -701,8 +701,12 @@ legal-info: dirs legal-info-clean legal-info-prepare $(foreach p,$(PACKAGES),$(p
cat support/legal-info/README.warnings-header \
$(LEGAL_WARNINGS) >>$(LEGAL_REPORT); \
cat $(LEGAL_WARNINGS); fi
- @echo "Legal info produced in $(LEGAL_INFO_DIR)"
@rm -f $(LEGAL_WARNINGS)
+ @(cd $(LEGAL_INFO_DIR); \
+ find * -type f -exec sha256sum {} + | LC_ALL=C sort -k2 \
+ >.legal-info.sha256; \
+ mv .legal-info.sha256 legal-info.sha256)
+ @echo "Legal info produced in $(LEGAL_INFO_DIR)"
show-targets:
@echo $(PACKAGES) $(TARGETS_ROOTFS)