summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-04-16 23:20:17 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-04-17 10:55:23 +0200
commita49b81ed69e3da1f7854efcab8133081ee367556 (patch)
tree32491e7158a88743e5877f1060454794828b68d4 /Makefile
parent04d0a5793fd802b1bcd091cfdd84a464d438579e (diff)
Revert "core: also display the custom help with our main help"
This reverts commit 0a767deba004c920e7824543380cffbb298507f8. Turns out that the custom help is not available when the $(O) directory has not been configure yet (i.e. when there is no .config already filled). Rather than trying to work around this limitation with dirty hacks, just revert this feature. After all, this will not prevent an external.mk from providing custom help anyway; it's just not gonna be advertised nor displayed with the main help. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 55735ea73..d205ac9eb 100644
--- a/Makefile
+++ b/Makefile
@@ -895,9 +895,7 @@ endif
rm -rf $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
$(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE)
-help: help-internal help-custom
-
-help-internal:
+help:
@echo 'Cleaning:'
@echo ' clean - delete all files created by build'
@echo ' distclean - delete all non-source files (including .config)'
@@ -970,6 +968,7 @@ endif
@echo ' source-check - check selected packages for valid download URLs'
@echo ' external-deps - list external packages used'
@echo ' legal-info - generate info about license compliance'
+ @echo ' help-custom - print help about custom actions (if any)'
@echo
@echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build'
@echo ' make O=dir - Locate all output files in "dir", including .config'