summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>2016-06-14 17:31:10 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-07-02 12:00:24 +0200
commita5f3513b220015bceed2de231e90fe6e4b4431b5 (patch)
treec1071b5edf6ef6cdc148ad6fbabc175371f52f19 /Makefile
parent71574a65e80d04db193432a7525eb49f1acdf614 (diff)
reproducibility: override locale and timezone
And export BR2_REPRODUCIBLE for post-build / post-image scripts. [Peter: Extend commit message, move export together with our other exports, add comment explaining why we override local/timezone] Signed-off-by: Gilles Chanteperdrix <gilles.chanteperdrix@xenomai.org> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 41f02745a..027f21c90 100644
--- a/Makefile
+++ b/Makefile
@@ -213,6 +213,13 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-include $(BR2_CONFIG)
endif
+# timezone and locale may affect build output
+ifeq ($(BR2_REPRODUCIBLE),y)
+export TZ=UTC
+export LANG=C
+export LC_ALL=C
+endif
+
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands
ifeq ("$(origin V)", "command line")
@@ -410,6 +417,7 @@ endif
# Scripts in support/ or post-build scripts may need to reference
# these locations, so export them so it is easier to use
export BR2_CONFIG
+export BR2_REPRODUCIBLE
export TARGET_DIR
export STAGING_DIR
export HOST_DIR