summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-12-01 23:22:51 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-12-01 23:24:07 +0100
commitcc257ee493bbf3261417908684dbff834d853ae6 (patch)
treecca896590d214d7bc90aad71fb8a76465438242b /Makefile
parent2723fa4a5066b8820b4ff03e2912ccea9ea7c5e0 (diff)
parent01e3d2eff15eb2535c4c15eb4f62467a50fe6a5f (diff)
Merge branch 'next'
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 26430de8a..b2535d394 100644
--- a/Makefile
+++ b/Makefile
@@ -818,10 +818,13 @@ ifeq ($(NEED_WRAPPER),y)
$(Q)$(TOPDIR)/support/scripts/mkmakefile $(TOPDIR) $(O)
endif
-# printvars prints all the variables currently defined in our Makefiles
+# printvars prints all the variables currently defined in our
+# Makefiles. Alternatively, if a non-empty VARS variable is passed,
+# only the variables matching the make pattern passed in VARS are
+# displayed.
printvars:
@$(foreach V, \
- $(sort $(.VARIABLES)), \
+ $(sort $(if $(VARS),$(filter $(VARS),$(.VARIABLES)),$(.VARIABLES))), \
$(if $(filter-out environment% default automatic, \
$(origin $V)), \
$(info $V=$($V) ($(value $V)))))