summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2016-03-09 23:58:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-10 23:49:46 +0100
commite049994086e64ad28aeccb524473752118e1fd8e (patch)
treed7ace05549f7ac6efef0c61f0aecbf95fb6c5c6e /Makefile
parent73c37f070b1b698dac6e309638c69d9ded162241 (diff)
core: use $(CURDIR) to set TOPDIR
This changes saves a shell call and uses a variable automatically set by make [1]. [1] http://www.gnu.org/software/make/manual/make.html#Quick-Reference Signed-off-by: Samuel Martin <s.martin49@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f2822a2ca..98c8dc79e 100644
--- a/Makefile
+++ b/Makefile
@@ -69,7 +69,7 @@ endif
.NOTPARALLEL:
# absolute path
-TOPDIR := $(shell pwd)
+TOPDIR := $(CURDIR)
CONFIG_CONFIG_IN = Config.in
CONFIG = support/kconfig
DATE := $(shell date +%Y%m%d)