summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-09-11 15:55:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-17 16:21:00 +0200
commite76b4fd103cd18c374ea7aa1e7f2e76ab02c00ca (patch)
treeed3c096376077ab232e435cfac4023201d277b79 /Makefile
parentc2d80a8c5d8b97cdc84c297a3d2d6896fff6560b (diff)
core: distclean is a noconfig target
When the .config contains invalid configuration *(e.g. two providers for a same virtual package), it is not possible to run "make distclean" because the .config file is sourced and packages interpreted in this case. Add distclean to the noconfig list, so that we can run it in all cases. However, this meand that DL_DIR is no longer set, and thus the default download location never removed. We fix that by always removing the download location, so that if it is the one configured we still remove it (no change) and if it is not the one configured, we remove an non-existing location and leave the user's location intact (no change either). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index dfef02189..92feff312 100644
--- a/Makefile
+++ b/Makefile
@@ -86,7 +86,7 @@ export BR2_VERSION_FULL := $(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setlo
noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig allyesconfig allnoconfig silentoldconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
- print-version olddefconfig
+ print-version olddefconfig distclean
# Some global targets do not trigger a build, but are used to collect
# metadata, or do various checks. When such targets are triggered,
@@ -905,13 +905,10 @@ clean:
$(LEGAL_INFO_DIR) $(GRAPHS_DIR)
distclean: clean
-ifeq ($(DL_DIR),$(TOPDIR)/dl)
- rm -rf $(DL_DIR)
-endif
ifeq ($(O),output)
rm -rf $(O)
endif
- rm -rf $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
+ rm -rf $(TOPDIR)/dl $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
$(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE)
help: