summaryrefslogtreecommitdiff
path: root/boot/at91bootstrap3
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-29 19:33:22 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-06 11:04:59 +0200
commit0eba4759fab9d093afacac77a0ac31f1f0b3cceb (patch)
treeccebbcb4f86905d319d33da1e4a724a7d41b17f0 /boot/at91bootstrap3
parentea8edb95144456529ad3047bce86b7449438ca42 (diff)
packages: apply custom patches using *.patch instead of <pkg>-*.patch
Several packages have some logic to apply custom patches that existed before the BR2_GLOBAL_PATCH_DIR mechanism: at91bootstrap, at91bootstrap3, barebox, uboot and linux. Currently, the logic of those packages to apply custom patches is to match <package-name>-*.patch, which is not consistent with what we've done for patches stored in the package directory, and for patches stored in BR2_GLOBAL_PATCH_DIR: in such cases, we simply apply *.patch. Therefore, for consistency reasons, this commit changes these packages to also apply *.patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'boot/at91bootstrap3')
-rw-r--r--boot/at91bootstrap3/at91bootstrap3.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/boot/at91bootstrap3/at91bootstrap3.mk b/boot/at91bootstrap3/at91bootstrap3.mk
index 098e7bfe3..b780617b3 100644
--- a/boot/at91bootstrap3/at91bootstrap3.mk
+++ b/boot/at91bootstrap3/at91bootstrap3.mk
@@ -21,8 +21,7 @@ AT91BOOTSTRAP3_MAKE_OPTS = CROSS_COMPILE=$(TARGET_CROSS) DESTDIR=$(BINARIES_DIR)
ifneq ($(AT91BOOTSTRAP3_CUSTOM_PATCH_DIR),)
define AT91BOOTSTRAP3_APPLY_CUSTOM_PATCHES
- $(APPLY_PATCHES) $(@D) $(AT91BOOTSTRAP3_CUSTOM_PATCH_DIR) \
- at91bootstrap3-\*.patch
+ $(APPLY_PATCHES) $(@D) $(AT91BOOTSTRAP3_CUSTOM_PATCH_DIR) \*.patch
endef
AT91BOOTSTRAP3_POST_PATCH_HOOKS += AT91BOOTSTRAP3_APPLY_CUSTOM_PATCHES