summaryrefslogtreecommitdiff
path: root/boot/barebox
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2015-04-28 16:34:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-21 23:50:49 +0200
commit7241aee4ed7d85659a0eb0f369d8a3a44ffc176e (patch)
tree167113a12e070bc25c7a1299c3c7f6b35a010d36 /boot/barebox
parente34e12c5c3e0b851ac672603307ac300067ccf54 (diff)
barebox: add option to specify config fragments
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/barebox')
-rw-r--r--boot/barebox/Config.in6
-rw-r--r--boot/barebox/barebox.mk1
2 files changed, 7 insertions, 0 deletions
diff --git a/boot/barebox/Config.in b/boot/barebox/Config.in
index a250f3b34..53d80139b 100644
--- a/boot/barebox/Config.in
+++ b/boot/barebox/Config.in
@@ -91,6 +91,12 @@ config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
help
Path to the barebox configuration file
+config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
+ string "Additional configuration fragment files"
+ help
+ A space-separated list of configuration fragment files,
+ that will be merged to the main Barebox configuration file.
+
config BR2_TARGET_BAREBOX_BAREBOXENV
bool "bareboxenv tool in target"
help
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 294acbd4b..7e530371c 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -64,6 +64,7 @@ BAREBOX_SOURCE_CONFIG = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE))
endif
BAREBOX_KCONFIG_FILE = $(BAREBOX_SOURCE_CONFIG)
+BAREBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES))
BAREBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
BAREBOX_KCONFIG_OPTS = $(BAREBOX_MAKE_FLAGS)