summaryrefslogtreecommitdiff
path: root/boot/barebox
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-12-23 09:37:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-23 09:54:14 +0100
commitd831f2496441b5454de6a6dc0b4abb3804b94c88 (patch)
treef85d88afe6120cadabb6a42bfd58c36ba47ce343 /boot/barebox
parentb8d2e3b545dd40549d14d589472fd1ddf9c3da98 (diff)
Fix fallout after generated defconfig support
Fix improper use of qstrip; use correct variables. Fixes #8546. Reported-by: craigswank@gmail.com Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/barebox')
-rw-r--r--boot/barebox/barebox.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index f36ca70f6..7715dafe6 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -112,7 +112,7 @@ ifeq ($(BR2_TARGET_BAREBOX)$(BR_BUILDING),yy)
# We must use the user-supplied kconfig value, because
# BAREBOX_KCONFIG_DEFCONFIG will at least contain the
# trailing _defconfig
-ifeq ($(or $(BAREBOX_KCONFIG_FILE),$(BAREBOX_KCONFIG_DEFCONFIG)),)
+ifeq ($(or $(BAREBOX_KCONFIG_FILE),$(call qstrip,$(BR2_TARGET_BAREBOX_BOARD_DEFCONFIG))),)
$(error No Barebox config. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG or BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE settings)
endif
endif