summaryrefslogtreecommitdiff
path: root/boot/syslinux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-05-02 19:10:28 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-05-03 21:33:32 +0200
commit8b8f9004f475d29c14347af3764dd766417e0ee9 (patch)
treed5f3d78e2052b4ec3576cb312351c1ff4b92cdf8 /boot/syslinux
parent09e7b4c89159a3e48f463b0a22e649c4fc12f4b3 (diff)
boot/syslinux: prepare to install non-core images
Currently, we hard-code the path to the images we install, and expect them to be from the core/ sub-dir. Not all images we can install are located in core/. For example, the efi boot images (to come later) are not located in core/. Prepare the upcoming installation of extlinux by not expecting images be in core/. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Lundquist <lists@zelow.no> Cc: Frank Hunleth <fhunleth@troodon-software.com> Tested-by: Frank Hunleth <fhunleth@troodon-software.com> Tested-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot/syslinux')
-rw-r--r--boot/syslinux/syslinux.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index 0faa81f6e..a1eb39401 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -28,12 +28,12 @@ define SYSLINUX_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) INSTALLROOT=$(HOST_DIR) install
endef
-SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_ISOLINUX) += isolinux.bin
-SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_PXELINUX) += pxelinux.bin
+SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_ISOLINUX) += core/isolinux.bin
+SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_PXELINUX) += core/pxelinux.bin
define SYSLINUX_INSTALL_IMAGES_CMDS
for i in $(SYSLINUX_IMAGES-y); do \
- $(INSTALL) -D -m 0755 $(@D)/core/$$i $(BINARIES_DIR)/$$i; \
+ $(INSTALL) -D -m 0755 $(@D)/$$i $(BINARIES_DIR)/$${i##*/}; \
done
endef