summaryrefslogtreecommitdiff
path: root/boot/uboot
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-06-02 14:52:12 -0300
committerPeter Korsgaard <peter@korsgaard.com>2015-06-02 22:57:16 +0200
commit16b8e813c810fde2fe3655c696edf1e76a7d27ba (patch)
tree4b728bc765bbc2e4176f9de061c6f14fc24dede7 /boot/uboot
parent3eb61964640bc40b3a2106aaa525f62926920ef6 (diff)
boot/uboot: remove deprecated network settings option
It's been deprecated since the 2014.05 release, so a year has passed. Add legacy info as well to raise a warning when it's used. [Peter: Remove entire config.h fixup handling] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in46
-rw-r--r--boot/uboot/uboot.mk13
2 files changed, 0 insertions, 59 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 4f014995c..e884cc016 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -192,52 +192,6 @@ config BR2_TARGET_UBOOT_OMAP_IFT_CONFIG
endif
-menuconfig BR2_TARGET_UBOOT_NETWORK
- bool "Custom Network Settings"
- depends on BR2_DEPRECATED_SINCE_2014_05
- help
- Custom network settings for U-boot
-
-if BR2_TARGET_UBOOT_NETWORK
-
-config BR2_TARGET_UBOOT_SERVERIP
- string "server ip"
- default "10.175.196.221"
- help
- TFTP server ip address
-
-config BR2_TARGET_UBOOT_IPADDR
- string "ip address"
- default "10.175.196.18"
- help
- Target ip address
-
-config BR2_TARGET_UBOOT_GATEWAY
- string "gateway ip"
- default "10.175.196.1"
- help
- Gateway ip address
-
-config BR2_TARGET_UBOOT_NETMASK
- string "netmask"
- default "255.255.255.0"
- help
- Network Mask
-
-config BR2_TARGET_UBOOT_ETHADDR
- string "ethernet address"
- default "04:25:fe:ed:00:18"
- help
- Target MAC address for the ethernet interface.
- This should be changed for production units
-
-config BR2_TARGET_UBOOT_ETH1ADDR
- string "ethernet 2 address"
- help
- Target MAC address for the second ethernet interface.
-
-endif # BR2_TARGET_UBOOT_NETWORK
-
config BR2_TARGET_UBOOT_SPL
bool "Install U-Boot SPL binary image"
depends on !BR2_TARGET_XLOADER
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 410d8d8a6..8c10c6123 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -125,19 +125,6 @@ define UBOOT_CONFIGURE_CMDS
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
$(UBOOT_BOARD_NAME)_config
- @echo >> $(@D)/include/config.h
- @echo "/* Add a wrapper around the values Buildroot sets. */" >> $(@D)/include/config.h
- @echo "#ifndef __BR2_ADDED_CONFIG_H" >> $(@D)/include/config.h
- @echo "#define __BR2_ADDED_CONFIG_H" >> $(@D)/include/config.h
- $(call insert_define,DATE,$(DATE))
- $(call insert_define,CONFIG_LOAD_SCRIPTS,1)
- $(call insert_define,CONFIG_IPADDR,$(BR2_TARGET_UBOOT_IPADDR))
- $(call insert_define,CONFIG_GATEWAYIP,$(BR2_TARGET_UBOOT_GATEWAY))
- $(call insert_define,CONFIG_NETMASK,$(BR2_TARGET_UBOOT_NETMASK))
- $(call insert_define,CONFIG_SERVERIP,$(BR2_TARGET_UBOOT_SERVERIP))
- $(call insert_define,CONFIG_ETHADDR,$(BR2_TARGET_UBOOT_ETHADDR))
- $(call insert_define,CONFIG_ETH1ADDR,$(BR2_TARGET_UBOOT_ETH1ADDR))
- @echo "#endif /* __BR2_ADDED_CONFIG_H */" >> $(@D)/include/config.h
endef
define UBOOT_BUILD_CMDS