summaryrefslogtreecommitdiff
path: root/boot/uboot
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-03-11 11:32:24 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-03-15 22:47:47 +0100
commit21b25d28fc7af3bb1b2c55e4a46e0d067ebc0081 (patch)
treef0233f24aefffe74901a37cc1e1826eb619ef03b /boot/uboot
parentf80ad2fd73f792039417cab53cbcb3de1d1ca1a0 (diff)
uboot: remove deprecated BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR option
It's been deprecated for a year now so remove it. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in12
-rw-r--r--boot/uboot/uboot.mk10
2 files changed, 0 insertions, 22 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index f1d3d2adc..0e79734d2 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -90,18 +90,6 @@ config BR2_TARGET_UBOOT_VERSION
default BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION \
if BR2_TARGET_UBOOT_CUSTOM_GIT || BR2_TARGET_UBOOT_CUSTOM_HG
-config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
- string "custom patch dir"
- depends on BR2_DEPRECATED_SINCE_2015_05
- help
- If your board requires custom patches, add the path to the
- directory containing the patches here. The patches must be
- named uboot-<something>.patch.
-
- Most users may leave this empty
-
- NOTE: Use BR2_TARGET_UBOOT_PATCH instead.
-
config BR2_TARGET_UBOOT_PATCH
string "Custom U-Boot patches"
help
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index d539b3123..f9a3ff828 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -100,16 +100,6 @@ endef
UBOOT_POST_EXTRACT_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
UBOOT_POST_RSYNC_HOOKS += UBOOT_COPY_OLD_LICENSE_FILE
-# Prior to Buildroot 2015.05, only patch directories were supported. New
-# configurations use BR2_TARGET_UBOOT_PATCH instead.
-ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
-define UBOOT_APPLY_CUSTOM_PATCHES
- $(APPLY_PATCHES) $(@D) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) \*.patch
-endef
-
-UBOOT_POST_PATCH_HOOKS += UBOOT_APPLY_CUSTOM_PATCHES
-endif
-
# Analogous code exists in linux/linux.mk. Basically, the generic
# package infrastructure handles downloading and applying remote
# patches. Local patches are handled depending on whether they are